I have a 2011 yamaha grizzly 700 that I can t figure out what wrong with

I have a 2011 yamaha grizzly 700 that I can't figure out what wrong with. Ok I changed the spark plug on it wen I did an oil change. Wen I crank up bike it was popping and back fireing. Ok I thought I was the ignition coil so I change that. It startling smoking from the new ignition coil now the dash lights don't work or come on. Nothing comes on at all!! Bike won't even turn over unless I jump the solonoid but still no power. Can anybody help me?

33 comments
  • Sounds like the cdi smoked

  • Check wiring harness at ecm, the way they are positioned it holds mud and water and corrodes wires mine did same thing before

  • Joey Ventura

  • Check the fuses

  • Did all is good

  • Check all your grounds and check voltage going to and from the key and the kill switch

  • Check start solenoid fuse

  • I just had that problem and i changed all my fuses and put a new battery in it and it fired right up

  • That's what I'm gonna do first

  • I literally just had that problem yesterday

  • What was it doing?

  • Did any lights kick on? Did your screen kick on? Did your fuel pump kick on?

  • Before you did all that?

  • Nothing would come on but my underglow my screen didnt come on my relays my fuel pump nothing worked but my underglow so i changed the ignition fuse and the singal fuse and the battery and it fired right up

  • Damien Tackett damm I'm goin try that today lol I hope it works

  • Good luck

  • Damien Tackett thanks man

  • Np

  • What size & year is your bike?

  • Let me know if it works

  • Mines a 09 700 grizzly special edition with power steering Chris Bourgeois

  • When you changed all the fuses was they good?

  • And did you try jumping it off before you fixed it?

  • They showed good but some times if a fuse shows good itll still be bad

  • Yea.i tried everything befor i changed the fuses and battery

  • Okk gotcha

  • I need them rims and sliverbacks off yours lol

  • You live to far lol I wanna go with 31" OL2s

  • Im only about an hr and 45 mins lol i got 28 outlaws

  • Damien Tackett ok ok not back. If I get it running I'll sell mine for a low price.

  • Alright

  • Jessie Wells

  • If it was sputtering and popping then you may have sheared the flywheel key...I'd start there. You'll need a puller to pull the flywheel and verify that the woodruff key hasn't sheared. That would throw off your timing and cause these symptoms.