• My 2009 Raider S started back firing real bad and get worst the hotter the...

    My 2009 Raider S started back firing real bad and get worst the hotter the engine heats up. Thing I did: changed air filter, sparkplugs, O2 sensor. No exhuast leak. Does the Raider have a "cold cylinder sensor"??? Running really rich ...

    Old plugs black.

    16 comments
    • wouldnt backfiring mean a sticking exhaust valve?

    • Do you have an aftermarket fuel processor?

    • No but I do have cobra dragsters .... they were on bike when I bought it. I am starting to think it's the throttle position sensor .... backfiring as I back off on throttle. ..... looks like I'll have to pay for the stealership to tell me what's wrong

    • If the backfire is on the deceleration only side, that's normal. Some do it more than others. But, double check everything is working and such, if so , no stealership needed...

    • At this point "I don't know that I don't know" if that makes sense. I'll pay the money to have them give me an estimate and move on from there.

    • Even in 5th I let off throttle just a bit backfiring ..... it's un-rideable too me.

    • Did it pop as much before your maintenance work ? Another thing to check is exhaust gaskets ...

    • This started out of the blue and got worse, I changed air filter same results, changed sparkplugs, new O2 sensor, with no results. I sprayed carb cleaner around exhaust fittings engine did not bog down . Bike does seem sluggish

    • Try smoke around exhaust. The other thing only works on the intake side...

    • Intake side ... near jugs?

    • Exhaust gaskets are at head of pipes, no intake there. If one or both of the gaskets are a tiny bit out of alignment or a piece came loose and is allowing exhaust out it will run like crap n pop like crazy ...

    • Ok I'll have my old lady blow vape on them ....

    • Yup, works well, if even a little unsure change them, cheap compared to the stealer, lol ...

    • Yes thanks friend

    • Check the bolts on your exhaust pipes. I bet they are a little loose nea tje front of the bike. The excess air will cause major backfire

    • After I drilled out my pipes mine back fired on decel until I installed a fuel processor. Now it still does it occasionally depending on the humidity.